Cannot satisfy -package-id X11-1.9.1-As84WI1VImVHquwEDPbrTE

For some reason, when I do something about Haskell (install a package), I often get this error:
<command line>: cannot satisfy -package-id X11-1.9.1-As84WI1VImVHquwEDPbrTE
I have the X11 Haskell libs installed via cabal-install. I don’t know what it means, but it frustrates me :triumph:.
Does anybody know how to fix this?

Mhh never met that error, are you using Arch by any chance?

1 Like

Yes, I am using Arch. Is some recent version of a package broken?

Arch provides only dynamic libraries iirc, hence some quizzical errors now and then.

If you do not mind some curl | sh, ghcup is an option, other being downloading ghc/cabal yourself — what I do — or using stack; all three do not require root.

Otherwise if you want to continue with the Arch approach, your may also want to ask on specific channels like #arch-haskell on freenode.

1 Like

What version of cabal-install are you using?

Do you have any more details for something reproducible?

1 Like

cabal-install version
I’m using Arch, so it’s probally the latest version.

I think this might be an instance of this “bug”: I also ran into it and fixed it by going into ~/.ghc/x86_64-linux-<ghc-version>/environments/default and removing the line containing package-id X11-1.9.1-As84WI1VImVHquwEDPbrTE. To avoid this issue in the future you should avoid using cabal install --lib for now.


I deleted the line, but the error still appears :frowning_face:. Should I try doing the same but in root’s home dir?

I don’t think you should run any of the cabal commands with sudo, so there should be nothing Haskell/Cabal related in root’s home dir.

Does it still give exactly the same error, including the same X11-1.9.1-As84WI1VImVHquwEDPbrTE name?


I think tried both with sudo and without. I really want to use XMonad as my WM, but it doesen’t work because of this error. I really want a solution.

Just tried finding ~/.ghc/x86_64-linux-<ghc-version>/environments/default in root’s home and the default folder does not exist.

Actually, when I recompile XMonad, it now says: <command line>: cannot satisfy -package-id data-default- Instead of X11.

It seems like OS related issue …it may help to submit more details, like which OS version with which ghc version you are trying to build XMonad …try to verify you could build any other haskell package in this ENV

1 Like

You shouldn’t use sudo with cabal. Please remove any /root/.ghc or /root/.cabal folders if they exist.

<command line>: cannot satisfy -package-id data-default-

Now also remove the line that contains that package form the ~/.ghc/.../default file. Continue removing each line that is reported in this way.

I use Arch Linux, so I’m using the latest of everything.