LLVM backend missing for some builds?


I wanted to try today to compare native builds with -fvia-llvm, however, the backend seems to be missing in my GHC. Specifically, it says

mateusz@mateusz-thinkpad:~/random$ ghc -O2 -fvia-llvm Solution.hs
Loaded package environment from /home/mateusz/.ghc/x86_64-linux-9.2.5/environments/default
ghc: unrecognised flag: -fvia-llvm

Usage: For basic information, try the `--help' option.

Indeed, it seems that I don’t have this option:

mateusz@mateusz-thinkpad:~/random$ ghc --show-options | grep via

I thought that the LLVM backend is available by default. If not, how should I enable it?

For reference, I installed GHC via ghcup, it downloaded the following archive:

[ Info  ] downloading: https://downloads.haskell.org/~ghc/9.2.5/ghc-9.2.5-x86_64-fedora27-linux.tar.xz as file /home/mateusz/.ghcup/tmp/ghcup-9d078700ef35ae2b/ghc-9.2.5-x86_64-fedora27-linux.tar.xz

System: Ubuntu 22.04, x86_64 GNU/Linux, llvm installed (version 14.0.0)

EDIT: sorry for the confusion, the flag is -fllvm, not -fvia-llvm :roll_eyes: