Stack build failing

I have the following line in my stack.yaml

resolver: lts-15.5

but I am getting this error on stack build:


C:\CRIME\haskell-call>stack build
Downloading lts-15.5 build plan ...
RedownloadInvalidResponse Request {
  host                 = "raw.githubusercontent.com"
  port                 = 443
  secure               = True
  requestHeaders       = []
  path                 = "/fpco/lts-haskell/master//lts-15.5.yaml"
  queryString          = ""
  method               = "GET"
  proxy                = Nothing
  rawBody              = False
  redirectCount        = 10
  responseTimeout      = ResponseTimeoutDefault
  requestVersion       = HTTP/1.1
}

``

I think it is understanding that I have a HTTP_PROXY variable, since I can ask stack update, and it updated the indexes (and I saw the traffic over the proxy).

Hard to say since you only posted the request but did not include the response. Last time I had a similar problem upgrading Stack fixed it. See https://stackoverflow.com/questions/57516944/stack-new-command-failing-to-download-build-plan-for-lts-14-1

@mduerig I did do a $stack update, but I still get that error. When I try that url in my browser (https://raw.githubusercontent.com/fpco/lts-haskell/master//lts-15.5.yaml) I get a 404. I don’t think turning on fiddler would give more. I also don’t like the look that it says the proxy is Nothing.

Here is the reponse:

 "C:\\sr\\build-plan\\lts-15.5.yaml" (Response {responseStatus = Status {statusCode = 404, statusMessage = "Not Found"}, responseVersion = HTTP/1.1, responseHeaders = [("Connection","keep-alive"),("Content-Length","15"),("Content-Security-Policy","default-src 'none'; style-src 'unsafe-inline'; sandbox"),("Strict-Transport-Security","max-age=31536000"),("X-Content-Type-Options","nosniff"),("X-Frame-Options","deny"),("X-XSS-Protection","1; mode=block"),("Via","1.1 varnish (Varnish/6.0)"),("X-GitHub-Request-Id","0B50:7C66:18A912:1D98AF:5E77EBB0"),("Accept-Ranges","bytes"),("Date","Sun, 22 Mar 2020 22:51:21 GMT"),("Via","1.1 varnish"),("X-Served-By","cache-lga21962-LGA"),("X-Cache","HIT, HIT"),("X-Cache-Hits","5, 1"),("X-Timer","S1584917482.682791,VS0,VE0"),("Vary","Authorization,Accept-Encoding"),("Access-Control-Allow-Origin","*"),("X-Fastly-Request-ID","ac1b322382ce86ca3857cfc8b6d4bf0f1747dff3"),("Expires","Sun, 22 Mar 2020 22:56:21 GMT"),("Source-Age","54")], responseBody = (), responseCookieJar = CJ {expose = []}, responseClose' = ResponseClose})

Stack version (running on win10)

C:\CRIME\haskell-call>stack --version
Version 1.9.3, Git revision 40cf7b37526b86d1676da82167ea8758a854953b (6211 commits) x86_64 hpack-0.31.1
1 Like

You should do a stack upgrade.

As your output shows, your stack version is old. Current version is 2.1.3

1 Like

Yes, that works. Thank you for your patience.

1 Like