Stack build on windows does not have rename permissions?

Why do I get a permissions violation with stack build on windows? See below for version of stack and the error message about renaming files. This happens even when I run as ADMIN, so it seems to be more than just a folder’s permissions issue.

C:\CRIME\haskell-call>stack --version
Version 2.1.3, Git revision 0fa51b9925decd937e4a993ad90cb686f88fa282 (7739 commits) x86_64 hpack-0.31.2

C:\CRIME\haskell-call>stack build
Stack has not been tested with GHC versions above 8.6, and using 8.8.3, this may fail
Preparing to install GHC to an isolated location.
This will not interfere with any system-level installation.
Already downloaded.
Already downloaded.
Already downloaded.
Decompressing ghc-8.8.3.tar.xz...

7-Zip 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18

Processing archive: C:\Users\ysg4206\AppData\Local\Programs\stack\x86_64-windows\ghc-8.8.3.tar.xz

Extracting  ghc-8.8.3.tar

Everything is Ok

Size:       2555330560
Compressed: 204702116
Extracting ghc-8.8.3.tar...
Extracted total of 10091 files from ghc-8.8.3.tar
C:\Users\ysg4206\AppData\Local\Programs\stack\x86_64-windows\ghc-8.8.3-tmp1040\ghc-8.8.3\: renamePath:MoveFileEx "C:\\Users\\ysg4206\\AppData\\Local\\Programs\\stack\\x86_64-windows\\ghc-8.8.3-tmp1040\\ghc-8.8.3\\" "C:\\Users\\ysg4206\\AppData\\Local\\Programs\\stack\\x86_64-windows\\ghc-8.8.3\\": permission denied (Access is denied.)

What I have seen, is that stack is downloading the GHC compiler as a tar, and the issue seems when it tries to explode the tar. I tried manually exploding the TAR, but stack install (or build) deletes that folder and tries to download again. Any help would be appreciated.