.stan.toml file with emacs+HLS

On a recent update STAN [1] warnings started to appear when using emacs+HLS.
I addressed some of the warnings (thanks!). But I want to disable others.
I tried both putting a .stan.toml file in the project root and then in ~.
But nothing changed. Still got the warnings.

The .stan.toml file:

type = "Exclude"
filter = "all"
scope = "all"

I am using:

  • via devenv
    • haskell-language-server-9.4.8
    • ghc 9.4.8
  • via home-manager
    • emacs 29.1

How does one control STAN in this configuration.

[1] : stan: Haskell STatic ANalyser

HLS ignores Stan config, please consider upgrading to the latest HLS release,

That said, stan is disabled by default in

thanks: if was using

haskell-language-server-9.4.8 --version
haskell-language-server version: (GHC: 9.4.8)

Was it enabled by default recently? I didn’t know why it had started showing up all the time, and thought it was a misconfigured system on my side. Tbvh stan in hls was a bit too much for me.

Yes, it was re-added and enabled by default in, but it didn’t allow for using .stan.toml files for its configuration. Now it does check for config files, but has to be enabled explicitly in your editor settings.